tipps - Einträge für September 2008

  • September, 2008
  • Menschen, Gespräche, Fortbildung und mehr ::: Nachlese Barcamp Stuttgart

    Da wir uns schon vor längerem entschlossen hatten, am Barcamp Stuttgart teilzunehmen, blieben wir trotz Baustelle Zuhause dabei. Das vorerst letzte Barcamp zu viert, da Joscha jetzt bald in London studieren wird. Insgesamt hat es uns allen gut gefallen, insbesondere die Organisation klappte prima, nochmals danke an Jan und das Orgateam. Für mich ist die Mischung aus mehreren Punkten bei Barcamps besonders wichtig:
    • an Sessions teilnehmen
    • wenn möglich selbst eine Session anbieten
    • Menschen kennenlernen, wiedertreffen
    • Gespräche und weitere Diskussionen am Rande

    Sessions am Samstag

    Samstag war ich bei folgenden Sessions:

    Zukunft der Onlineredaktion

    (Bild der erarbeiteten Übersicht auf Flickr von thurgau) von Saim Alkan Es folgte meine eigene Session, die danach folgende habe ich lieber mit Gesprächen am Rande verbracht.

    Web 2.0 und Recht. UGC - Chance oder Risiken?

    von Carsten Ulbricht Kurz vor Sessionbeginn ging ich nachsehen, was zum Schluss noch angeboten wird. Bei einer stand:

    Web 2.0-Tools Einsatz für Unterricht

    prima, das klingt ja interessant, war mein erster Gedanke. Der zweite war, "Moment, die Schrift kennst du doch... ;-) (Bild des Sessionplans auf Flickr von Frank Hamm). Meistens versuchen wir vor allem in die Sessions anderer zu gehen und möglichst nicht alle in dieselbe. In diesem Fall interessierte mich jedoch Rolands Session mehr als alle anderen, deshalb ging ich dort hin. Da er wenig präsentierte und viel Platz für Diskussion und Austausch ließ, lohnte sich das auch, denn ich erfuhr mehr, als er darüber erzählt hatte und hätte. Der Ausklang des Abends mit viel Raum für Gespräche im nahegelegenen Mash war ebenfalls gelungen.

    Sessions am Sonntag

    Am Sonntag begann ich mit der Doppelsession von Robert und Oliver. Mit Robert hatte ich mich bereits vorab schon darüber unterhalten, wie Blogs als solche noch einflussreicher und länderübergreifender werden könnten.

    Keynote im Dialog bauen: Weblogs and the World "Revolution"

    Robert Basic und Oliver Gassner werden demnächst einen Vortrag dazu in Serbien beim South East European Blog Festival halten, siehe BlogOpen. Danach war nur noch Zeit für eine Session, da wir früher wegmussten. Diese Zeit nutzte ich daher lieber für Gespräche am Rande. Unter denen, mit denen ich einen längeren Austausch hatte waren: Alexa, Christian, Kirstin, Robert, Roman und Ute (in alphabetischer Reihenfolge)

    Meine Sessionideen

    Die Linux-Session, die ich ursprünglich anbieten wollte, habe ich dann doch gestrichen. Die Webstandards wollte ich auf jeden Fall machen, für Linux gab es ein weiteres Angebot vorab. Am Samstag wurden soviel Sessions angeboten, da kam es nicht in Frage. Mit Marco, der vielleicht was zu Fedora Linux machen wollte, hatte ich am Samstag kurz gesprochen, ob wir vielleicht gemeinsam was anbieten würden. Dank großer Baustelle zu Hause (Umbau mit Wänden raus usw.), mussten wir jedoch am Sonntag früher zurück, daher war mir eine weitere Session zuviel. Als Co-Produktion bei direkter Anfrage am Sonntagmorgen hätte ich es mir noch überlegt, aber so war es auch gut.

    Webstandards, warum, wozu und wie?'

    Angeboten habe ich die Webstandards am Samstag, mit dem Hinweis, dass es mir vor allem um Austausch und Diskussion geht. Bereits vorab gab es schon einige Interessenten im Wiki des Barcamps und die Session war auch sehr gut besucht. Mit über zwanzig Teilnehmern hatte ich gar nicht gerechnet. Es ging dann eher in die technische Richtung:
    • Browserunterschiede
    • warum gibt es noch kein HTML 5
    • ärgerlich, dass sich noch immer nur wenige Eigenschaften von CSS 3 einsetzen lassen
    • wieso sollte man Javascript möglichst nur dann einsetzen, wenn es auch ein Fallback gibt
    • unterschiedliche Ansprüche für mobile Endgeräte, z.B. mit verschiedenen Themes in Blogs gelöst
    • ...
    Somit passte die für alle Zielgruppen (Einsteiger, Fortgeschrittene und Special Interest) angekündigte Session, im zweiten Teil, nicht mehr für alle. Wie schon beim Blogcamp in Zürich, habe ich das Ganze ohne die Präsentation gehalten. Letztes Mal hatte ich den Adapter vergessen, dieses Mal wollten mein Laptop und der Beamer nicht miteinander kooperieren. Technische Probleme mit allen elektronischen Geräten bin ich ja glücklicherweise gewohnt... Sobald es bei Elektronik ein Problem gibt, bin ich sicher in der Nähe. ;-)

    Flipcamp geplant

    In Anbetracht dessen, habe ich einen weiteren Grund die Idee eines Flipcamps gut zu finden. Gedacht ist dabei an ein Barcamp, welches keinen Internetzugang, keine Laptop, Mobiles usw. zulässt. Daher gibt's auch keinen Beamer, aber ein Flipchart, daher der Name Flipcamp. Wer mehr darüber wissen will oder zeigen möchte, dass er oder sie teilnehmen würde, bekommt weitere Informationen auf der Seite Flipcamp. Dort kann auch diskutiert werden und es können Themenvorschläge gemacht werden. Mich reizt die Idee mal ein Barcamp ohne Elektronik zu besuchen.
  • Praktisch und schnell synchronisieren oder Daten sichern mit rsync

    Standardmäßig arbeite ich mit einem 17"-Laptop, welches tacita heißt. Immer mal wieder, insbesondere für unterwegs bevorzuge ich jedoch kleinere und leichtere Notebooks, z.B. mein 13"-Laptop devika. Datensicherungen gibt's auf einen internen Server, der heißt satan. Jeweils von Hand zu kopieren ist aufwändig und fehleranfällig. Schneller und leichter geht es so:

    Grundlage für alle Aufrufe

    • als root auf dem Quellrechner im obersten Verzeichnis, also bei / stehen
      • um das gesamte home-Verzeichnis abzugleichen, z.B. von tacita auf devika
        • rsync -avz --delete ./home/ute devika:/home/
      • das gesamte home-Verzeichnis sichern, ohne alte Dateien zu überschreiben oder gelöschte auf dem Server ebenfalls zu löschen
        • rsync -avz  ./home/ute satan:/home/
      • oder einzelne Bereiche abgleichen, z.B. nur die Mails abgleichen
        • rsync -avz --delete   ./home/ute/.kde/share/apps/kmail devika:/home/ute/.kde/share/apps/
    • rsync ist ein gewöhnliches Linuxkommando, im Zweifel hilft man rsync weiter
    • -avz steht für komprimierter "archive mode", damit bleiben Rechte, Eigentümer usw. erhalten, und die Daten werden für den Transport komprimiert, d.h. es geht schneller
    • --delete braucht man, um geänderte und verschobene Dateien abzugleichen. Habe ich z.B. auf tacita die Datei beispiel.txt gelöscht und diese Datei existiert auf dem Zielrechner, dann wird sie bei --delete gelöscht, sonst bleibt sie erhalten
    So lässt sich schnell und nebenbei sowohl ein Abgleich, wie auch die regelmäßige Datensicherung durchführen.
  • Favicon aktualisieren im Firefox 3

    • Favicons Übersicht
    • Favicons im Detail
    • Firefox Cache

    Ich habe neue Favicons fürs Blog gebastelt, da ich recht viel mit der Optik arbeite. Ich habe wann immer möglich unterschiedliche Symbole, nicht nur im Browser, ich nutze das seit Jahren ebenso für meine Mailordner und die Ordner im Dateimanager Konqueror. Mir fällt es leichter schnell aufgrund eines Symbols etwas zu finden, als wenn ich nur Namen lese.

    Für alle eigenen Seiten bekommen auch die Adminbereiche z.B. von WordPress ein eigenes Favicon, so sehe ich auf Anhieb welcher Tab, welchen Bereich enthält. Das Bild Favicons im Detail verdeutlicht das, offen sind gerade nur von mir betreute Seiten und Bereiche.

    Neue Favicons werden ja in keinem Browser sofort angezeigt, insbesondere, wenn sie weiterhin denselben Namen haben. Die meisten Browser aktualisieren die Favicons jedoch nach dem ersten Schlißen und erneuten Öffnen des Browsers. Außerdem lassen sich die anderen Browser direkt austricksen, da lässt sich das Favicon von Hand löschen. Der Firefox ist da hartnäckiger, der hat keinen für mich auffindbaren Eintrag, der auf das Favicon verweist und neu laden, öffnen und schließen hilft alles nicht.

    Nun gut, bis hierhin ist das nichts Neues, das war auch schon bei den älteren Versionen so ähnlich. Früher, als die Oberflächen meist noch nicht deutsch sprachen gabs unter Preferences irgendwo die Möglichkeit den Cache zu leeren, unter dem Begriff Cache. Seit 1996 nutze ich Browser, zunächst den Netscape aus dem ja später die Mozilla-Browser hervorgingen. In meiner Welt gab es immer einen irgendwo einen Knopf oder einen Tab, der auch Cache hieß.

    Vor kurzem hatte ich schon einmal einen Favicon geändert und suchte recht lang, bis ich den Firefox dazu bewegen konnte das Ding auch anzuzeigen. Heute ging das schon wieder los, ich habe alle Einstellungen durchsucht, aber nirgends war ein Eintrag Cache leeren.

    Gefühlte Stunden später, nach mehreren Versuchen im Netz einen Hinweis für Firefox 3 zu finden, gabs dann im Archiv des Usenets einen Hinweis, unter Datenschutz / Private Daten gibts noch weitere Einstellungsmöglichkeiten. Ich bin die Einzige, die meinen Rechner nutzt, deshalb habe ich normalerweise keinen Grund private Daten zu löschen. Ich kam auch nicht auf die Idee, dass der Cache dort versteckt ist. Ja, es hat eine gewisse Logik, wenn ich tatsächlich private Daten löschen will, dann muss auch der Cache geleert werden... Ich wollte aber keine privaten Daten, sondern den Cache leeren, deshalb suchte ich dort erst gar nicht.

    In meinem Seamonkey ist alles noch so, wie ich das in Erinnerung hatte unter: Einstellungen / Erweitert / Cache lässt sich der Cache leeren. Ich habe grad keinen Firefox 1.x mehr, aber ich glaube da war das auch noch so ähnlich. Ich brauche diese Funktion ja nur sehr selten, nämlich ausschlißlich dann, wenn ich ein Favicon ändere, bei allen anderen Änderungen genügt zumindest  ein STRG oder Umschalttaste und neu laden, oder allerhöchstens braucht es mal einen Neustart.

    Da ich das bestimmt wieder vergessen würde, wenn ich es nicht aufschreibe, habe ich es jetzt mal hier notiert. Meist genügt es mir, es geschrieben zu haben, dann erinnere ich mich zumindest, dass da irgendwas war und gehe mal suchen... ;-)

  • ...endlich mal wieder eine neue WordPress-Version ;-)

    Na gut, das ist ein bisschen ironisch, denn grad dachte ich, die eigenen und betreuten Blogs seien soweit aktuell, da steht doch im Adminbereich schon wieder:

    "eine neue Version 2.6.2 ist verfügbar"

    Ja, ich finde es sinnvoll, wenn Fehler und Lücken so schnell wie möglich behoben werden, dieses Mal hat auch alles problemlos geklappt ***mal vorsichtshalber auf Holz klopfend*** Klasse finde ich die Geschwindigkeit der deutschen Entwickler, die die angepasste Version 2.6.2, wie gewohnt, innerhalb eines Tages zur Verfügung stellten. Ein bisschen strukturierter und nicht ganz so häufige Aktualisierungen wären jedoch zuweilen schon nett. Ich habe brav wie immer, erstmal lokal probiert, was passiert, anschließend alle Datenbanken gesichert und erst dann aktualisiert... Klar fange ich jeweils erstmal mit dem Blog an, bei dem es am wenigsten auffällt, falls was wiederhergestellt werden muss. Es folgen die eigenen Blog und erst wenn da alles ok ist, gehe ich an Kundenblogs.

    Plugin quote-comments

    Das Plugin quote-comments (Kommentare zitieren) von Peter Kröner läuft jetzt auch hier. Nach einigem Rumprobieren und nachfragen, kam ich beim ersten Blog lokal zu einer Lösung. Ich musste die comments.php meines Themes ein bisschen anpassen, um validen Code zu bekommen. Im Plugin habe ich in der wp-quote-comments.php statt eines Paragraphs (p) auf <li class="quote_comments"> umgestellt, sonst passte es nicht in meinen Themes. Das erste, ein internes Blog, lief nachdem ich den relativen Pfad in der wp-quote-comments.js  von ../../../wp-content/plugins/wp-quote-comments/ auf absolute Pfade vom root aus /bloggt/wp-content/plugins/wp-quote-comments/ geändert hatte. Beim Rumprobieren hatte ich diverse Versionen und irgendwann wusste ich gar nicht mehr, was ich alles geändert hatte. Ich habe dann nochmal mit den Ursprungsversionen angefangen. Dabei fiel mir auf, dass die Seiten plötzlich nicht mehr valide waren. An der Stelle ist das Plugin noch empfindlicher als der Validator, bei mir verweigerte es bei jedem Fehler seinen Dienst. Da ich selbst auf validen Code achte, ist das kein Problem, aber ich hatte nicht damit gerechnet. Hier hatte ich einen Fehler zwischen den lokalen Tests und dem Hochspielen eingebaut und suchte das Problem zunächst in den Pfaden, die waren es jedoch nicht, denn kaum war der Fehler weg, war auch das Plugin zufrieden und zitierte so, wie ich mir das vorgestellt hatte. So ganz nebenbei tauchte noch ein Problem auf, welches viel Zeit kostete, für das ich noch keine Lösung habe, da ich die Ursache nicht kenne, welches aber nicht so gravierend ist. Erstmals hatte ich Unterschiede im Quelltext zwischen meiner lokalen und der Serverversion. Das Plugin schreibt mir lokal in jeden Kommentar:

    id="quote_comments_loader"

    Sobald es auf dem Server ist, beschränkt es sich jedoch darauf, das exakt einmal zu tun. Leider dauerte es ziemlich lang, bis ich kapiert habe, dass das so ist. Bis dahin hatte ich nach, mir unerklärlichen, Fehlern im Validator gesucht... :-(
  • Sprachproblem bei Update auf WordPress 2.6.1

    Vor einigen Tagen, habe ich dieses Blog aktualisiert auf die Version 2.6.1. Wie immer hatte ich vorher lokal alles installiert und ausprobiert. Irgendwann bei einer Änderung, hatte ich lokal plötzlich das Problem, dass die Sprache im Adminbereich und im Blog nicht mehr deutsch war. Da ich einiges hin und her probiert hatte, auch mit verschiedenen Plugins, mal installiert und dann wieder entfernt, dachte ich es wäre nur ein lokales Problem und spielte alles hoch. Leider stimmte das nicht, auch hier auf dem Server war anschließend alles im Adminbereich englisch. Nur dieser Bereich wäre ja nicht so schlimm, allerdings sind damit auch alle Angaben wie Datum und Texte, die direkt von WordPress kommen englisch. Ich recherchierte an verschiedenen Stellen, unter anderem in der FAQ des deutschen WordPress-Forums. Ich probierte alle Hinweise aus, aber nichts half. Als nächstes wollte ich wissen, ob das Problem in der Datenbank zu suchen ist. Zuerst schaute ich mal rein, ob es da weitere Sprachinformationen gibt, da war jedoch nichts. Dann installierte ich lokal eine völlig neue Datenbank, denn mehrere andere neu aufgesetzte Blogs kamen ja mit derselben Kombination WP 2.6.1 und dieselben Plugins zurecht. Wieder kein Ergebnis, dieselben Dateien ergeben bei Neuinstallation wieder englische Ergebnisse. Nächster Schritt alle Plugins deaktivieren, umstellen auf's Standardtheme in deutscher Version und alle WordPress-Dateien aus einem Blog kopieren, die mit deutsch zurecht kommen. Vorher natürlich sicherstellen, dass auch die lokale Version gesichert ist, nicht dass die einzige Originalversion auf dem Server liegt. Wieder kein Erfolg, alle geänderten Dateien von einem Blog, welches die deutsche Sprache anzeigt als Grundlage ändern nichts daran, dass wieder alles auf Englisch ist. So ganz allmählich gingen mir die Ideen aus, denn wenn es weder die Datenbank, noch die Dateien, noch das Theme, noch die Plugins waren, was könnte denn dann noch sein? Nun, das einzige, was jetzt noch anders war, war die wp-config. Ich hatte zwischendurch schon einige Male mit Änderungen der Sprachangabe und verschiedenen Sprachdateinamen an unterschiedlichen Stellen experimentiert, da ja auch der Pfad zwischen WP 2.3 und WP 2.6.1 für Sprachdateien anders ist. Statt /wp-includes/languages findet man die Sprachdateien ja inzwischen unter: /wp-content/languages Da ich von Hand schon einige Male probiert hatte, dachte ich, die einzige Chance ist noch, die relevanten Zeilen zu kopieren. Tja, und genau das war's! Jetzt spricht alles wieder brav deutsch. Hätte ich die Kommentare in der Datei genau gelesen, hätte ich drauf kommen können. Nun, das hatte ich jedoch nicht. :-(

    Lösung des Sprachproblems

    define ('WPLANG', 'de_DE'); /* That's all, stop editing! Happy blogging. */ define('ABSPATH', dirname(__FILE__).'/'); require_once(ABSPATH.'wp-settings.php'); // define('ABSPATH', dirname(__FILE__).'/'); // require_once(ABSPATH.'wp-settings.php'); // define ('WPLANG', 'de_DE'); Na, seht ihr den Unterschied? Ich habe es mehrfach nicht gesehen. Es gibt Definitionen, die dürfen stehen wo sie wollen, z.B.

    define('ABSPATH', dirname(__FILE__).'/');

    , das gilt jedoch nicht für die Sprachdefinition, die muss vor dem folgendenKommentar stehen.

    /* That's all, stop editing! Happy blogging. */

    Wie das passieren konnte?

    Für die Umbennenung des Blogs musste ich in der wp-config folgende Zeile eingeben:

    define('RELOCATE', true);

    Dabei habe ich wahrscheinlich versehentlich den Spracheintrag um eine Zeile verschoben... Nun gut, wieder was gelernt, jetzt sind jedenfalls wieder alle Ausgaben deutsch und vielleicht hilft es ja noch jemand... ;-)
  • Blogadresse geändert ::: Weiterleitungsprobleme mit .htaccess

    Wie ja bereits erwähnt, hat sich die Blogadresse hier geändert. Die Feeds gibts neu hier:  http://miradlo.net/bloggt/feed und nicht mehr unter: miradlo.net/blog_miradlo. Ich habe sofort einige Weiterleitungen ausprobiert, die jedoch partout nicht so recht klappen wollten. Insbesondere der Feed weigerte sich und wollte sich nicht umleiten lassen. Beim Recherchieren zur .htaccess, die den Apache steuert gab's unzählige Ideen und Vorschläge:
    • wie werden Feeds zu Feedburner umgeleitet
    • welches WordPress Plugin leitet wie um
    • wie leitet man überhaupt um
    Die ein oder andere Umleitung leitete zwar teilweise so um, wie ich wollte, hatte aber derart unangenehme Nebeneffekte, dass es auch keine Lösung war. Denn mit den versuchten Umleitungen für das gesamte alte Blogverzeichnis blog_miradlo auf bloggt, ließ sich der Feed nicht umleiten. Versuche, erst den Feed umzuleiten und dann den Rest gesamt, führten zu internen Serverfehlern (Error 500). Der eine oder andere sonstige Versuch hatte Probleme damit, dass es bisher noch anderer Stelle ein Bilderverzeichnis gab, was auch blog_miradlo hieß. Aber jetzt habe ich eine Lösung!

    Blog von einem Verzeichnis in ein anderes umleiten inklusive des Feeds

    RewriteEngine On

    RewriteRule ^blog_miradlo/(.*)$ http://miradlo.net/bloggt/$1 [R=301,L]

    Damit leitet es jetzt sowohl einzelne Aufrufe nach Beiträgen, wie auch den Feed brav um. Für diesen Fall ungeeignet waren folgende Möglichkeiten:

    Mit direkten Umleitungen der Feeds (auch für mehrere Versionen) passierte gar nichts:

    • RedirectPermanent /blog_miradlo/wp-rss.php http://miradlo.net/bloggt//wp-rss.php
    • RedirectPermanent /blog_miradlo/feed/ http://miradlo.net/bloggt/feed

    Auch angepasste Anleitungen, die einen Feed vom eigenen Blog zu Feedburner umleiten wollten nicht so, wie ich, egal ob diese: WordPress zu Feedburner umleiten oder sowas wie diese:

    • <IfModule mod_rewrite.c>
      • RewriteEngine on
      • RewriteCond %{REQUEST_URI} ^/?(/blog_miradlo/feed.*|comments.*) [NC]
      • RewriteCond %{HTTP_USER_AGENT} !^.*(FeedValidator) [NC]
      • RewriteRule ^feed/?.*$ http://miradlo.net/bloggt/feed [L,R=301]
      • RewriteRule ^comments/?.*$ http://miradlo.net/bloggt/comments/feed [L,R=301]
    • </IfModule>

    Als Zwischenlösung hatte ich deshalb alles auf die Blogstartseite umgeleitet, das klappte jedoch nicht mit den Feeds und auch nicht mit den einzelnen Beiträgen, aber es war zunächst einmal besser als nichts:

    • RedirectMatch 301 ^/blog_miradlo/(.*) http://miradlo.net/bloggt/
  • Mit Vista per virtuellem Host auf lokalem Webserver (Linux) testen

    Ich brauche es ja ganz selten, aber so ab und zu zum Testen muss es halt doch auch Windows sein. Zum Beispiel um den IE 7 (Internet Explorer) zu testen, wäre es ja schön, wenn das auch lokal klappt und nicht nur, wenn die Daten bereits auf dem Server sind. Die relevanten Daten habe ich natürlich trotzdem auf Linux, in meinem Fall auf tacita, das ist mein Standardrechner 17" Fujitsu Siemens Amilo Laptop mit 1920*1280 Auflösung, betrieben ausschließlich mit Gentoo Linux. Auf meinem kleinen Notebook, devika, ebenfalls ein Fujitsu Siemens Amilo Laptop mit etwa 1280 Auflösung, betrieben mit Dualboot, einerseits ebenfalls Gentoo Linux, jedoch zu Testzwecken mit Windows Vista.

    Apache Webserver und Rechnernamen

    Wir haben unsere Rechner so eingerichtet, dass auf allen ein Webserver läuft. Unsere Rechner sind im internen Netz daher auch mit fester IP erreichbar, z.B.
    • 192.168.13  tacita
    • 192.168.12 devika
    Sich die Zahlen zu merken ist bei mehreren Rechnern lästig und auch nicht nötig, deshalb können wir auf die Webserver der jeweiligen Rechner mit Namen zugreifen. Angenommen ich möchte von tacita aus, den Webserver von devika erreichen  dann genügt:
    • http://devika

    Virtuelle Hosts

    Da wir einige verschiedene Projekte bearbeiten, war es unpraktisch jedesmal den Apache neuzustarten (als root mit /etc/init.d/apache2 restart), deshalb nutzen wir virtuelle Hosts, damit kann man Projekte z.B. so aufrufen:
    • tacita_miradlo_net
    • tacita_miradlo_com
    • usw.

    Bestehenden Webserver auf Windows nutzen

    Ist pro Rechner nur ein localhost, aber keine virtuellen Hosts, eingerichtet, klappt das auch mit Windows. Ich greife dann z.B. von devika aus mit Windows Vista auf tacita mittels der IP 192.168.13 zu. Der localhost, der als Standard fungiert wird damit auch noch aufgerufen, selbst wenn es weitere virtuelle Hosts gibt. In vielen Fällen genügt das, denn auf Linux einen anderen localhost als Standard zu setzen, geht recht schnell. Mir jedenfalls ist das lieber, als zu sehen, wie ich irgendwas bei Windows einstellen kann. (Ja, stimmt, wenn ich es vermeiden kann, fasse ich es gar nicht erst an, dann klappt es zum Testen und mehr brauche ich nicht.) Das Ganze klappt jedoch nicht mehr, wenn z.B. ein Blog in einem Unterordner installiert ist, dann behauptet Vista, dass es die Seite nicht gäbe. Manchmal will ich jedoch auch Blogs auf Windows testen, bevor ich irgendwas ins Netz stelle. Selbstverständlich will ich nicht vorher erst das ganze Projekt auf Windows installieren, sondern nur auf den Webserver des Rechners zugreifen, auf dem das Projekt gerade liegt.

    /etc/hosts auf Windows

    Der Aufruf mit IP und Projektname, z.B. 192.168.13_miradlo_net klappt nicht, da findet Vista ebenfalls nichts. In diesem Fall muss man tatsächlich Vista beibringen andere Hosts zu erkennen. Im Netzwerk existieren diese Hosts ja bereits, Windows greift auf dasselbe interne Netzwerk zu, es fehlt also nur an den korrekten Namen. Es existiert auch unter Windows ein Verzeichnis etc und eine Datei hosts, die so aufgebaut ist, wie das eben unter Linux üblich ist. Das Problem bei Vista ist zunächst, die Datei zu finden...
    • c:\Windows\System32\drivers\etc\hosts
    ...anschließend, sie auch ändern zu dürfen. Die Anleitung dazu, mit dem Aufruf des Editors als Administrator habe ich bei LANtastic gefunden. In der hosts konnte ich dann wie gewohnt meine Einträge machen, z.B:
    • 192.168.13     tacita_miradlo_com.name_des_internen_netzes      tacita_miradlo_com
    • 192.168.13     tacita_miradlo_net.name_des_internen_netzes       tacita_miradlo_com
    So kann ich auch von Vista aus, z.B. ein Blog testen und alles verhält sich so, wie später auf dem Server:
    • http://tacita_miradlo_net/blog/
    Ich gehe davon aus, dass das so ähnlich auch mit einem Vista auf VM-Ware (virtuelle Maschine) klappen müsste, das habe ich jedoch noch nicht getestet. Mit XP und VM-Ware geht es auf jeden Fall... Klasse, oder?! ;-)

Seite 1 von 1, insgesamt 7 Einträge